Share this content
0
5
3253

Importing from Sage 50 Excel option greyed out

Hi there

I have just set up my new PC, installed Sage 50 (v16, 2010), and all works fine. I tried to import my journals from an XLSX file, as I have been doing for years on the old PC, but the Excel option is greyed out, so will only allow import from csv.

new PC details:

Windows 7 Professional

Excel 2010

Sage 50 Accounts Plus 2010 v16.0.17.0158

I have a SSD to store my programs and a traditional spinning HDD to store my data.  All the sage data ie Company.000, Company.001 etc folders on are on the HDD.  Sage itself is installed on the SSD.  I told Sage (by editing the company (no extension) file) to find the data on the HDD, and it works fine.  The one thing it can't do is import from an xlsx file.

Does anybody know why this might be happening, and what I can do to make it work properly?

Thanks in advance.

Martin

Replies

Please login or register to join the discussion.

avatar
By pjowen
23rd Nov 2012 11:32

File - Save As*

Hi Martin,

 

If sage requires a csv file to be imported (like with other programs that require a simpler file) simply open your excel document and save the file as a csv file.

 

This should change the file to the format required by sage.

 

Regards

 

P J Owen

Thanks (0)
avatar
23rd Nov 2012 11:38

Thanks!

I had worked that out, and have done it, but it doesn't exactly answer the question of why it has happened, or how I can get back the functionality I have been using for years, which I find much easier than dealing with csv files and their inherent restrictions.

It's a workaround that will do for now, but it's not the answer.

Martin

Thanks (0)
avatar
By pjowen
23rd Nov 2012 12:19

I'm sorry for stating the obvious I wasn't sure of your computing knowledge. I think maybe a call to sage support, more of an IT issue than an accounting issue?

 

Regards

Thanks (0)
avatar
23rd Nov 2012 12:44

It sounds as if

Sage is not "seeing" the Excel installation.

You could try excel.exe /unregserver and excel.exe /regserver from the command prompt or, in similar circumstnaces, what I have found more effective* is to "repair" the Office 2010 installation.

* though not with Sage which I haven't had problems with.

Thanks (0)
avatar
26th Nov 2012 12:54

Solved...

Just to update anyone who might have this problem in future:

I asked our Sage supplier, the very helpful Ken Wood at East Yorkshire IT (EYIT) and this is his reply:

Apparently Excel 2010 is not supported by Accounts version 16 (2010).

The problem manifests itself exactly in the way you describe.

The Sage tech support team is sending me a knowledgebase article on this, I will send it down to you ASAP.

Upgrading to the latest program will cure this issue on your PC configuration.

The knowledgebase article is not very helpful, but if you want to look it up, it is here: http://www.sage.co.uk/asksage/viewarticle.asp?p_faqid=25731&DIV=SBD

So, as the first reply said, it's back to csv until we upgrade to a more up to date version next year...

 

Martin

 

Thanks (0)