Sage Accounts 2011 - Missing activities

Sage Accounts 2011 was working fine, but today it is missing all entries in the all the activities windows.  I have restored from backup, but the problem still exists.  Any ideas?

Comments

Missing Activities

johndon68 | | Permalink

First thing - if you run Check Data are there any errors?  If there are then you have data corruption that needs to be sorted out.

Assuming there are no errors, if you go to the Financials window, can you see all the transaction there?

I was also going to suggest that there may be some criteria set up but this would not affect all activity windows...

John

Missing Activities

chloeparrot | | Permalink

Hi John

Thanks for responding.

I have run Check Data and there are no errors.  All transactions are present in the Financials window.

Chloe

 

 

Activity

johndon68 | | Permalink

If you go Customers -> Activity and select a Customer who you know has transactions nothing comes up?

On the Activity screen, what appears in the 'Show' field?

If you've not already done so, run both ReIndex and Compress.

John

Lack of Activity

chloeparrot | | Permalink

I chose 2 Customers with known transactions, one with a balance and one without - the Activitity screens on both are blank.

The 'Show' field is set to 'Custom Range' with a date range of '01/01/1980 to 31/12/2099', 'Type' set to 'All' and 'O/S only' is unchecked.

I have run ReIndex and Compress - still no activities.

Chloe

 

Activity

johndon68 | | Permalink

If you change the Show to 'All Transactions' does it make a difference?

John

landscaper's picture

Is the box ticked?

landscaper | | Permalink

Is the show "o/s only"box clicked/ticked - if there is no outstanding balance then no transactions will show.  This is relevant to Sage 2010 and I haven't seen the screens for 2011 so sorry if this isn't relevant but I'm assuming it's pretty similar.

Activity

johndon68 | | Permalink

landscaper wrote:

Is the show "o/s only"box clicked/ticked - if there is no outstanding balance then no transactions will show.  This is relevant to Sage 2010 and I haven't seen the screens for 2011 so sorry if this isn't relevant but I'm assuming it's pretty similar.

The last post suggested that it wasn't ticked:

"and 'O/S only' is unchecked."

John

landscaper's picture

Sorry

landscaper | | Permalink

So sorry - what an idiot

Activity

chloeparrot | | Permalink

How strange, I don't have the option to Show 'All Transactions' - I only have:

'Last 30 days'

'Last 60 days'

'Last 90 days'

'This Financial Year'

'Custom Range'

 

Activity

johndon68 | | Permalink

Ah, All Transactions appears in v2012 but not v2011 - if you reselect Custom Range from the drop down, what are the settings on the Activity Range screen that appears?

John

Activity

chloeparrot | | Permalink

The Activity Range screen settings are:

Transaction Range

From: 0

To:      0

Transaction Type:

Type to Display : All Transactions

Outstanding Transactions Only - box is unchecked

Date Range:

From: 01/01/1980

To: 31/12/2099

 

Activity

johndon68 | | Permalink

chloeparrot wrote:

Transaction Range

From: 0

To:      0

 

Ah - that might be it then - the transaction range should default to a value of 1 for 'From' and the number of transactions to 'To' - as both settings are zero, nothing is being returned as there is no transaction 0.

Change the 'From' to 1 and set 'To' to 99999999 - the 'To' should then reset to the number of transactions.

I believe that will solve the problem.

John

Activity

chloeparrot | | Permalink

It won't let me change either value.

It comes up with a Warning, displaying the message

'Transaction number greater than the total number of transactions'

Yet the Financials Report showing all the transactions!!!

Activity

johndon68 | | Permalink

Does the number of transactions in the 'To' field not change to the actual number of transactions once you OK that message?

If it does not and still defaults to 0 then it would suggest that, despite what Check Data is showing that there is a problem with the data.  If you go to Help -> About -> System Information -> Directories, right click on the Data Directory and Open Folder. 

In that folder there should be a file SPLITIDX.DTA - if that file is missing or has a legnth of zero bytes then you do have a problem with the data.

 

John

Activity

chloeparrot | | Permalink

Both the 'To' and 'From' fields defaults to 0.

The file SPLITIDX.DTA, it's size is 20KB - which seems rather small to me - how big should it be?

 

Activity

johndon68 | | Permalink

That's fine, its size depends on the number of transactions on the system.

I'm not aware of any issues but is the software fully up to date (including Update 3 which is not automatically downloaded)?

John

Activity

chloeparrot | | Permalink

Yes, s/w up to date including Update 3.

Thank you so much for your help and patience in dealing with this problem - all your efforts are much appreciated.

Do you believe it would help if I uninstalled the program and started from scratch?

 

Activity

johndon68 | | Permalink

Does the Activity work as expected (including changing the transaction numbers) in the Demodata or Practice Data?

John

Activity

chloeparrot | | Permalink

Activity works as expected including changing the transaction numbers in Demodata.

Activity

johndon68 | | Permalink

That suggests that the problem is data related as, if it was a program issue I would have expected Demodata to fail as well...

If you'd be OK with sending me a backup I'd be happy to take a look, free of charge, to see if there are any problems not being reported by Check Data

John

Activity

chloeparrot | | Permalink

John

I'd be eternally grateful if you would look at the data for me.  Where should I send it to?

Chloe

Activity

johndon68 | | Permalink

Email a backup to john.donnelly@leyburnsolutions.com

John

Activity    1 thanks

johndon68 | | Permalink

As a footnote to this one in case anyone is interested, having had a look at the data, the problem turned out to be data corruption (fixable) albeit Check Data returned no problems so it took an awful lot of digging to find...

John

Activities    1 thanks

chloeparrot | | Permalink

My sincere thanks to John for all his efforts in resolving this issue for me.

Chloe

Add comment
Log in or register to post comments
Group: Sage 50 Accounts discussion group
An independent forum for Sage users to share ideas, tips and gripes