Share this content
4

Anyone having problems claiming CIS online? (Ltd)

Anyone having problems claiming CIS online? (Ltd) - HMRC website issue?

Didn't find your answer?

Hi,

I have a limited company that needs to have their CIS deductions offset against Corporation Tax. I have always applied for the transfer online using the HMRC claim form. Last time I did one was October 2019 and it went through fine.

I have tried to do one today using the same link and I am now greeted with the message "Register with the Agent Subscription Service". So I click register, and I am greeted with "You have signed in with your user ID for HMRC online services for agents. You need to sign out and sign in with your Agent Services Account".

Ok - so I have an Agent Services Account which was created in order to file MTD for VAT. So I log in with these credentials, 

And it takes me to my VAT online Agent Services Account. No mention of CIS refund applications anywhere......

Anyone else had the same issue and/or know a fix to get around it???

Or is it just HMRC websites being their usual crap selves?

Many Thanks

Replies (4)

Please login or register to join the discussion.

avatar
By SXGuy
10th Jan 2020 08:17

Try this.

Copy the url for "Register with the Agent Subscription Service", then log out of any session you have open with HMRC, close all web browsers, could even try clearing browsing history and include cached files and cookies.

Then re open a browser and paste the link, login using your ASA, see what happens.

Thanks (1)
Replying to SXGuy:
avatar
By marky74
10th Jan 2020 10:00

Thanks - tried but still got same result. Guess I will have to revert to the old method of either letter or telephone call!

Thanks (0)
avatar
By lesley.barnes
10th Jan 2020 10:06

I've just tried it and I'm getting the same message. I used it earlier in the year and it was ok. Must be usual HMRC rubbish.

Thanks (1)
avatar
By SXGuy
10th Jan 2020 11:12

If others are having issues then its likely HMRC;s systems.

They have been all over the place this last week, people unable to file vat under mtd, people cant login to their PTA or BTA.

I think there may be a widespread issue with most of their services.

Thanks (0)
Share this content