Companies House log in problems

Is the Companies House website at fault?

Didn't find your answer?

The Companies House website keeps rejecting my password. I use the reset password option but the link provided ( when it eventually arrives) doesn't work. When clicking on the link it goes to a page that shows only an error message : " An error occurred on client” . This happens whatever browser I use:Chrome, Microsoft edge or Firefox.

I can’t get through on your telephone helpline.

Any ideas as to what to do?

 

Replies (9)

Please login or register to join the discussion.

avatar
By D V Fields
13th Jan 2023 19:05

Unfortunately I have found many website (and software) very poor in communicating password rules. I now avoid trying to reset to the same “perceived” one as it often is accepted, let’s you log on only to find the next time it refuses as the check on a re-used password occurs after the reset. SAGE used to have a ten character limit on passwords - which only came to light when the same “perceived” password would log onto SAGE (it truncated characters after 10th) but failed via an ODBC connection (using all characters).

Personally I’ve found using a password manager has drastically reduced these incidents and great time savers.

Thanks (0)
avatar
By Geoff56
15th Jan 2023 08:12

A few weeks ago, Companies House began rejecting the password I had used for years. In trying several different approaches, I typed the letters in upper case whereupon the password was accepted again. Prior to that, I am sure CH had accepted both upper and lower case, but now I stick to upper case and have not had any further problems.

Thanks (1)
avatar
By rmillaree
16th Jan 2023 08:05

A strange thing sometimes happens with me.

Sometimes my password is rejected - only quick fix i have found is to get another person in the office to login from their computer - that works first time and then i am back up and running. I have tried different browsers that doesnt work but different computer does. All very strange and annoying if it happens when everyone else has shutup shop. Not sure if its some sort of time block for security reasons linked to my device - reset with successful login - i deffo havent exceeded my max login attemps ?

Note i have never reset the password and password is always cut and paste from same location so it doesnt really make much sense.

Thanks (0)
avatar
By richards1
19th Jan 2023 08:54

Do you have another computer, or mobile. Try logging in from a different machine. If that works then you know the problem is in the machine/browser combination you are currently using. If that is the case then reboot and or reinstalll one of the browsers and use that browser to login to Companies House. I have just used Companies House for a conformation statement and I had to reset my password. It all worked fine for me.

Thanks (1)
Replying to richards1:
avatar
By Rgab1947
19th Jan 2023 09:59

A link is established with the computer and the website (am a luddite with the acronyms). A different computer breaks the link.

I know, what do I know.

Thanks (0)
Head of woman
By Rebecca Cave
19th Jan 2023 09:07

I have now managed to reset the password and do the compliance statement. I think the CH website was at fault sending me to a deadend for password reset.

Thanks (0)
avatar
By jameswheelan
19th Jan 2023 09:57

I see you have managed to sort this Rebecca but thought I'd share my experiences.....

I too had this issue after Companies House recently reinvented the platform, after many emails back and forth and failed suggestions they gave me a this work around.

- Sign in to WebFiling and select the option to file a mortgage charge.

This takes you to the old login screen and allows you to login seamlessly!

Thanks (0)
Replying to jameswheelan:
avatar
By Guilford Accounting
19th Jan 2023 10:09

I had the same problem and they gave me this workaround; said they had IT problems they were trying to fix.

Not sure CH should be giving out workarounds to circumvert their own security systems!

Thanks (1)
carcouk
By Car.co.uk
18th Oct 2023 13:30

I recently encountered the Companies House login glitch, which caused a major delay in accessing essential documents for a crucial client meeting. It emphasized the urgency of addressing these technical challenges. Let's hope that the platform's administrators are actively working on a solution to prevent such disruptions in the future.

Thanks (1)