Share this content

Company Incorporation

What am I doing wrong?

Didn't find your answer?

Just went to incorporate two new companies for the first time since June this year and it seems I now have to create a government gateway account and a companies house account for each company. I am guessing I am doing something silly or something has changed with the setup process? Can someone provide the correct link because no matter how I try I cannot find the way I did it back in June!

Thanks!

Replies (8)

Please login or register to join the discussion.

avatar
By Calculatorboy
29th Oct 2020 16:51

Ask an accountant , but there will be a fee

Thanks (0)
avatar
By PandoraSleeps
29th Oct 2020 17:01

I usually google companies house web incorporation and go from there

Thanks (0)
avatar
By bettybobbymeggie
29th Oct 2020 17:08

I think I'm going mad because I just started the second setup and it didn't go through the motions of asking for a gateway ID, etc. so ignore me. I need a lie down.

Thanks (0)
blue sheep
By Nigel Henshaw
30th Oct 2020 09:36

Use software its far more efficient, we use inform direct

Thanks (0)
Replying to NH:
avatar
By Paul Crowley
30th Oct 2020 10:08

We use 1st formations
Let client do it
If needed on my computer

Thanks (0)
By Duggimon
30th Oct 2020 10:18

This is the link I use, never had such issues, but it's been a couple of months https://ewf.companieshouse.gov.uk/incorporation

edit: should have checked that first, looks like it has all changed. Guess we'll be looking in to the software options per above.

Thanks (0)
avatar
By bettybobbymeggie
30th Oct 2020 12:20

Actually it's a pretty useful service and also lets you register for CIS/PAYE at the same time which saves a bit of time later on.

Thanks (0)
Share this content