Iris problems (again!)

Can't enter bank details for repayments on Iris Elements CT600

Didn't find your answer?

Don't know if anyone has any solution, but I've tried to enter data in the "tax payments and repayments" section of the Corporation Tax return.  Iris brings up the data entry page, and allows you to enter data, but clicking on the "save" button does nothing.  Nor does clicking on the "cancel" button.  You're basically trapped unless you click on the back button of your browser.  I've tried it on a few clients, and the same happens.  There are no error messages, but something is stopping it from saving.

Anyone have any ideas?  I've lodged a support case with Iris, but not hopeful of any response any time soon as they took several days when I last raised an error with them.  

Replies (1)

Please login or register to join the discussion.

avatar
By LFM
08th May 2024 10:27

This will be no help but just checked back on a return where I entered bank details in a return I filed in early April and is appearing on the filed return.

Hope you get it sorted, please let us all know

Thanks (0)