Share this content
8

Problems with MTD access code

Agent account

Didn't find your answer?

I'm having a problem this afternoon getting an access code to file a clients VAT return. I've filed several MTD successfully using bridging software but today I get to the access code stage and the access code isn't coming through on the phone. The phone doesn't ring. The last three digits of the phone number shown on screen are correct. I've tested the telephone line and I can ring it from another phone and it will ring out. There is a dialing tone. I've checked service issues and nothing is listed there, I've tried to ring HMRC but the lines are all busy so I keep being cut off. Anyone got any ideas what is wrong and how I can fix it?

Replies (8)

Please login or register to join the discussion.

avatar
By lesley.barnes
26th Jul 2019 08:15

Problem solved - the access code is required for filing using the ASA account. I'm using bridging software and I have to confirm the access code twice the first time I file for each client and then just once afterwards for 18 months.
I don't know why it has happened. Each submission I've made previously has worked using the number I have had registered. I've certainly not changed it.
HMRC have reset the number and advised that it doesn't always work using a landline so it is better to use a mobile number. I've now set it up with a mobile number and its worked perfectly.

Thanks (0)
Morph
By kevinringer
01st Aug 2019 14:08

Re the ASA/bridging software debate and the number of times we have to text:
1. We use Sage desktop always filing via our ASA, we have to do 1x GOV.UK authentication for every client for every return - we've got some monthly returns and filed 3 months so far and have had to do it for every month.
2. We use Absolute bridging software filing via our ASA, we have to do 2x GOV.UK authentication for the first time for each client and don't need to do it for subsequent returns (I assume for 18 months).
3. We use QuickBooks online filing via our ASA, we have had to do 2x GOV.UK the first time for the first client and it's been hit and miss since: sometimes having to go as extreme as removing the ASA details from QBO and re-inputting them to get it to work, other times it has gone through no problem.

Thanks (0)
Replying to kevinringer:
avatar
By johnhemming
01st Aug 2019 14:48

In theory it is possible for
1. To only have to do one ASA authorisation every 18 months for all clients.
2. To only have one authorisation using the ASA every 18 months for all clients. There is a danger with separate ASA records in each clients that the refreshes get out of sequence and you could find problems with that.
3. There should only be one ASA authorisation every 18 months for all clients.

It might be for those that are requesting two authorisations that they are separately authorising the read and write scopes. My approach is to authorise three scopes at once which then means only one pass through the OAuth2 process.

In the last half hour I have been working on the production Agents API and I am finding that the authorisations don't last very long (under a day) and it comes up with the wrong error message, but I think that is because it is new. I have seen that the refreshes work perfectly with the write: vat and read: vat scopes. They also work perfectly on the ASA.

Very few people are using the Agents API in production, however.

What the software should do with an ASA is to store a single set of credentials and when a refresh is requested (after 4 hours) it will then maintain both the access and refresh tokens.

Thanks (0)
Replying to kevinringer:
avatar
By johnhemming
01st Aug 2019 16:56

Further to this I have been monitoring my service remotely in the last few minutes and I can confirm that multiple submissions are being made using the ASA without additional OAuth2 processing.

It is clear that the HMRC systems are working properly in connection with ASAs and if the MTD software is set up to share credentials properly then there is no normal need to reauthorise an ASA other than every 18 months.

Hence it is either an issue with the software or the way the software is configured that is causing this. HMRC'S OAuth2 processing is operating exactly as designed.

Thanks (0)
Share this content