Share this content

Registering a client for new taxes

Email received: "The application with reference number...has been received, etc."

Didn't find your answer?

Do any members on here have issues where there is a discrepancy between the reference number quoted on the acknowledgement when the submission is initially made and that quoted on the subsequent email?

Yesterday evening I submitted via my agent account using the "Registering a client for new taxes" service a new VAT registration and another unconnected for self assessment. I receive two emails back, one late last night the other early hours this morning but quoted totally difference reference numbers.

Is is just me?

Replies (5)

Please login or register to join the discussion.

avatar
By BudgetB
06th May 2021 11:38

I'm not sure the reference numbers on the returning emails have any relevance to anything unfortunately. It would be nice if they could put some kind of identifiable info on there so that when you've submitted several registrations on the same day and they come back to say there's a problem on one of them, that you could at least have half a hope of knowing which one it was!!

Thanks (0)
Replying to BudgetB:
avatar
By bettybobbymeggie
06th May 2021 12:05

Your reply surprises me because those references used to tie up. I have always been a bit pedantic in that I print to pdf the screen of the HMRC acknowledgement so I have a record of the registration and the reference. I then do the same when the emails came through (which also had a reference on them). It just seems to have stopped working that way in the last few weeks.

Thanks (0)
Replying to bettybobbymeggie:
avatar
By Hugo Fair
06th May 2021 13:08

Maybe it's "gone digital"?

Thanks (2)
avatar
By Refs1
06th May 2021 20:02

I thought it was just me! Yes seems odd. Had the same issue but not on all cases.

Thanks (0)
avatar
By bettybobbymeggie
07th May 2021 07:44

By way of an update, the VAT registration I submitted on Wednesday was confirmed via an email this morning containing the reference from the earlier email - but again not the same reference that was on the initial submission.

As Hugo has said above, it appears that HMRC have done an IT 'fix' on something that worked fine before.

Thanks (0)
Share this content